1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MK3 blinker issue

Discussion in 'Suzuki 250cc 2 Strokes' started by warnzie, Aug 8, 2019.

  1. warnzie

    warnzie Member Premium Member

    Messages:
    24
    Likes Received:
    6
    Trophy Points:
    13
    Joined:
    Oct 29, 2018
    Gender:
    Male
    Location:
    Australia
    My Bike:
    Suzuki RG250 Mk3
    Hi all, got a very strange issue on my rg and hoping someone will know the answer.

    Noticed my blinkers when turned on will stay solid and not blink. Thought flasher unit but here’s the strange thing, on idle they work absolutely fine, it’s not until you give it revs they stop blinking and stay solid????

    Any ideas?
     
  2. my67xr

    my67xr Bike Enthusiast Staff Member Premium Member Contributing Member

    Messages:
    3,486
    Likes Received:
    1,984
    Trophy Points:
    898
    Joined:
    Jun 18, 2016
    Gender:
    Male
    Occupation:
    Panel Beater, Spray Painter, Custom Fabricator
    Location:
    Adelaide, South Australia
    My Bike:
    Yamaha's, 1990 FZR250R 3LN3 , 1986 XT250TS 57R , 1984 IT200L 43G
    How many volt's is your battery getting at idle, and how many volt's at 4000 rpm's + ?
    The reg/rect could be faulty and be putting out too many volt's or not enough volt's ?
    Check a few of your globe's to see if they've gone black, headlight, stop tail and turn signal globe's and dash globe's etc (dash globe's are usually first to go black)

    If you find the reading's are good ^,
    i would be checking all the turn signal related connection's for corrosion and loose wire's, and check all the earth's are going to clean bare metal (Dielectric grease will help to stop corrosion on bare metal)
     
  3. Linkin

    Linkin The Apprentice Premium Member Dirty Wheel Club Contributing Member

    Messages:
    3,724
    Likes Received:
    2,175
    Trophy Points:
    943
    Joined:
    Mar 18, 2014
    Location:
    Sydney NSW
    My Bike:
    '99 YZF-R6, '99 GSF250VY
    Charging system problem... check the battery voltage with the bike running and again when you rev it / use the blinkers
     
    • Agree Agree x 2

Share This Page